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EZSurv™and FieldGenius

• FieldGenius (5.0 and higher) generates different data files including GNSS observation 
files (on the receiver SD card) along with an text file (FieldGenius *.raw file). The Post-
Processor requires these  two files to calculate post-processed positions.

• GNSS Observations files, as recorded by FieldGenius includes all required GNSS data for 
post-processing (observations and orbits). 

• EZSurv™updates the text file (*.raw) with post-processed positions. If you use the “Fill 
RTK failures” option, only “non-FIXED” positions will be updated.
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Post-Processing is a simple step 
inserted into the data flow.

Post-Processing simply rewrites 
the raw file with corrected 

positions
Post-Processing
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FieldGenius Trajectories

• Trajectories are created when a rover file (GNSS 
observations) is combined with base station data 
(covering the rover file time span). Trajectory may or 
may not include survey points. A trajectory is a typical 
RTK run.

• EZSurv™can automatically creates and post-process 
trajectories with the submitted GNSS data files. The 
match between rover files and Base Station data is 
automatically done.

Trajectory (or RTK Survey)

A typical FieldGenius file includes many survey points
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• Select Options... from the Tools menu.
• Select the Base tab. Click Add... to add a Base Station 

provider. Select a provider from the list and click OK. 
• Type the user name and password if required 

(commercial providers).
• Click Properties... to view the information about the 

selected base station provider (You can have info for 
every single base station of the provider).

Configuring Base Station Providers

See «Base Station Setting» Training Module for more details

To be done only once, if required
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• EZSurv™generates automatically all trajectories using field 
metadata («start and end time» of each observation file, as 
well as their status, static or kinematic)

• Select the Combinations tab from the Tools > Options.  In 
the Trajectories section, set the percentage of data coverage 
of your rover by the Base (typically we look for 100%)

• Also make sure that Maximum distance option is checked 
and input a proper distance tolerance (maximum distance 
between your rover and the Base)

Configuring Trajectory Parameters
To be done only once
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• When FiledGenius is used to collect RTK positions, and you want to control your RTK positions with 
EZSurv™, you have to set the same reference system in the PP software as the one used by the RTK 
infrastructure.

• This is important when you want to QA your positions with EZSurv™. If you are using your receiver in 
AUTONOMOUS mode, the synchronization between reference systems is no longer an issue.

• For example, in the USA, most of the RTK infrastructure are broadcasting corrections  with respect to 
NAD83 (CORS96 epoch 2002). 

• Before importing your FieldGenius data, set your Mapping Systems with the proper datum – IT HAS TO 
BE SET BEFORE IMPORTING YOUR DATA – EZSurv™is using these datum parameters to properly 
convert FieldGenius positions into WGS84 (see the «Mapping Systems» training Module).

FieldGenius Reference System
To be done only once

This is important only if RTK infrastructure is used
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• Usually, this has to be done once if the user always 
uses the same reference system.

• Select the General tab from the Tools > Options.  In 
the Units section, select your unit of measure 
(International Feet, Metric or US Survey Feet).

Configuring Unit of Measure
To be done only once
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See the «Default Parameters» training Module to properly set your process 
parameters:

• Processing mode (make sure it is differential)
• Constellation (GPS or GPS&GLONASS)
• Process interval (typically use the data interval)
• Ambiguity fixing mode
• Base Station search
• Precise orbits
• Etc.

Configuring the Process Parameters
To be done only once
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Collecting GNSS data with FieldGenius
4 different «Use Cases»
# Base Station Rover

1 Private Base: GNSS data recorded on SD card without 
FieldGenius (*.dat file)

*.raw and *.dat files recorded with 
FieldGenius for the rover

2 Private Base: A set of *.raw and *.dat recorded with 
FieldGenius specifically for the Base

*.raw and *.dat files recorded with 
FieldGenius for the rover

3* Private Base: One *.raw file for both unit (Base and Rover). That  will generates specific *dat files on 
each receiver

4 RTK infrastructure (network, VRS, etc), no Base Station 
data recorded by the user

*.raw and *.dat files recorded with 
FieldGenius for the rover

The «Use Case» #3 allows to use only one data collector. He sets the Base with FieldGenius, then he sets 
its rover, do its data collection, stops the rover, and then go back to the Base and stop it with Field Genius.
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Description of «Use Case» # 3
• Set your Base Station using FieldGenius:
� select your coordinate system (mapping/datum), 
� start recording GNSS observations as well as a raw file (ex.:Base09092011)
� input your base coordinate / create a point

• Set your rover with FieldGenius
� Create a new project file (not the same as the base, ex.: ROVER09092011)
� Conduct your survey 
� Stop your survey (project raw file raw)

• At the end of your survey, go back to your Base and properly close the Base file
• Transfer Base and Rover files to your PC for post processing (including GNSS observations recorded on the 

SD card)
See FieldGenius manual for complete setting of a Base and a Rover
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Description of «Use Case» # 4

• Set your rover with FieldGenius
� Create a new project file (ex.: ROVER09092011)
� If available, get corrections data (using a network, VRS or other)
� Conduct your survey 
� Stop your survey (project raw file raw)

• Transfer your FieldGenius files to your PC for post processing (including GNSS observations recorded on 
the SD card)

• In the Post-Processor, set your Base Station Provider
• If you were working in RTK, before importing your data, make sure to properly set Mapping 

Systems/datum in order to avoid bias in the RTK-PP coordinate comparison

See FieldGenius manual for complete setting of a 
Rover
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Importing your data - Use Case # 1

• For the rover: Select Observations > Import… or simply 
drag and drop your raw file into the observations folder of 
the Post-Processor.

• For the Base: Select Observations > Import… or simply 
drag and drop your *.dat file into the observations folder 
of the Post-Processor

View/Project Manager

1 Private Base : GNSS data recorded on SD card without 
FieldGenius (*.dat file)

Rover: *.raw and *.dat files recorded 
with FieldGenius for the rover

This «use case» is typically used when users are working only in PP
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Importing your data - Use Case # 1

• In the Project Manager windows (Observation Folder), 
set your Base station file is set as a “Base” (select 
the ”Base” status using the right click and select “base”).

• Go to the Site Editor using Edit > Site. Enter its 
coordinate (in proper mapping system/datum).
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Importing your data - Use Case # 2

• For the rover:  From the Project Manager, select 
Observations > Import… or simply drag and drop your *.raw
file into the observations folder of the Post-Processor.

• For the Base: From the Project Manager, select select 
Observations > Import… or simply drag and drop your *.raw
file into the observations folder of the Post-Processor

View/Project Manager

2 Private Base : A set of *.raw and *.dat recorded with 
FieldGenius specifically for the Base

Rover: *.raw and *.dat files recorded 
with FieldGenius for the rover

In this «Use Case», EZSurv™ will properly sets the Base coordinates (extracted form the *.raw file) as well as 
the file status to «Base»
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Importing your data - Use Case # 3

• From the Project Manager, select 
Observations > Import… or simply drag and 
drop your raw file into the observations folder 
of the Post-Processor.

• This should properly import all files related to 
your Base       and rover View/Project Manager

3 Private Base: One *.raw file for both unit (Base and Rover). That  will generates specific *dat files 
on each receiver

In this «Use Case», EZSurv™ will properly sets the Base coordinates (extracted form the *.raw file) as well 
as the file status to «Base»
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Importing your data - Use Case # 4

• For the rover: Select Observations > Import… or simply 
drag and drop your raw file into the observations folder 
of the Post-Processor.

• For the Base: you have to set a Base Station provider to 
get Base Station data to do your PP (refer to Base 
Station Setting training module).

View/Project Manager

4 Base: RTK infrastructure (network, VRS, etc), there is 
nothing to do

Rover: *.raw and *.dat files recorded 
with FieldGenius for the rover
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When your *.raw file is imported into the Observations folder, you have access to a 
list of all your field positions in Analysis > Survey Sites > Field Coordinates.

Processing RAW files – Field positions
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Processing FieldGenius Data– Start Processing
Select Process Auto... from the Tools menu to start the GNSS post-processing (or 
press F9 on the keyboard). The following steps are performed automatically: 

> scan for base stations. 
> merge base data (if required). 
> define trajectories/baselines. 
> post-process the data. 

If you are using a Base Station provider, before processing, make 
sure your base station data is available. Some providers are 
generating hourly files whereas others are using daily files! See 
with your provider for the exact time of availability of their base 
station files on their FTP site. 
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• The Process Summary is displayed once the GNSS post-processing is completed. 

• Close the Process Summary windows, select Save as from the File menu,EZSurv™ will 
propose you a project file name and a folder, then click Save. 

• Also, when you import your original *.raw file, the Post-Processor save a copy of the 
original with a suffix _RT1.raw.

Processing RAW files – Updating RAW 

When you save your Post-Processor project, EZSurv™ automatically updates your *.raw 
file with post-processed positions.
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After post-processing, you have access to a list of all your positions in 
Analysis > Survey Sites > Post-Processed Coordinates.

Processing RAW files – PP positions
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Processing RAW files / PP-RTK comparison

• You can verify that your “post-processing reference system” is well aligned with 
your “RTK reference system”, by comparing RTK and post-processed positions. 
This is a good QA control tools

• RTK Fixed positions should 
fall within few centimeters 
from post-processed Fixed 
positions.

Useful for QA control
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Processing FieldGenius Data– Back to the data flow

• At this point in time, you are back, with your 
corrected/updated *.raw file, to your usual data 
flow.

• If there is a need for, the original copy of the 
*.raw file is saved with a suffix _RT1.raw in the 
same directory.

*.raw
*.dat

Usual user 
data flow

Post-Processor

*.raw
*_RT1.raw
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Site Coordinates- Export

• Site Coordinates can be exported using the Post-Processor in different ASCII formats:
� ASCII geographic
� ASCII Mapping
� DXF

• It could also be exported in a custom CSV 
format

• The export is access through Tools > Export > 
Sites… (you select the site(s) to be exported, 
select your format and click OK)
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Site Coordinates– CSV Export

Tools > export > Sites…
• Click       on to access the Profile 

Editor
• Then select your parameters, 

order them using the «Move up»
and «Move down»

• Save it under a specific name

CSV export can be configured according to your needs. All parameters related to 
a site can be exported. Some parameters are required (like the site names). You 
can configure a CSV output and save it using a profile.
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Sites Coordinates– A Google View !
You can export your survey points in Google Earth format using Tools > 
Export > Features.

File to be exported (your current file)

Output directory

Output format (select Google Earth KMZ)
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Processing FiledGenius Data in short

• There is an easy compatibility between EZSurv™ and FieldGenius filed data
• There are 4 different «Use Cases» that are compatible with EZSurv™
• The only issue is to properly set in EZSurv™ the same reference system as 

the one used by the RTK infrastructure (to be done once)
• Once properly setup, the processing is summarized as a simple «drag and 

drop» (of you filed data) followed by F9 !


